升级内核导致无法使用VMware的解决
🎞️
升级内核导致无法使用VMware的解决
Tags
Linux
VMware
Deepin

问题描述

升级到比较新的内核后, 一般vmware无法使用, 会显示有两个模块没有安装, 但是仿佛无法通过它的方式编译安装. 但是也有解决的办法. 办法的前提是内核的gcc版本和你当前的gcc版本相同

手动编译安装模块

终端中输入以下命令
git clone https://github.com/mkubecek/vmware-host-modules.git
cd vmware-host-modules/
git checkout workstation-x.x.x  #补丁的版本号
git fetch
make
sudo make install
补丁的版本号可以到github储存库去找, 一般来说, 如果你下载安装最新的vmware, 那么就用最新的版本号
安装成功之后, 有时也会提醒你 could not open /dev/ vmmon,Please make sure that the kernel module 'vmmon' is loaded.
解决方法
service vmware start

参考文献

Loading Comments...